Map Widget Editor Layers Tab

<< Click to Display Table of Contents >>

Navigation:  Enterprise > Widgets > Map > Widget Editor  >

Map Widget Editor Layers Tab

To change the properties of the Map widget, open the Widget Editor by selecting the More Options Ent-More_Options-Icon icon in the upper right corner of the widget to display the drop-down menu and then select the Edit menu option. The Map widget properties are divided into six tabs. Changes made on any tab will not be preserved until the user clicks Save on the Widget Editor header.

 

The Layers tab displays all layers added to the Map widget in a grid view. For each layer, the grid view provides the layer name, layer type, and URL and denotes whether the layer is visible by default and set to show in the Layer List. Use the Layers tab to add layers, edit layers, delete layers, and sort the view order of map layers.

Ent-Map_Widget_Editor_Layers

 

Add New Map Layer

 

The following steps describe the general process to add a new map layer. Selection of the map layer type will dictate options available in the layer dialog.

1.Click the Add Layer Ent-New_Role_Button-Icon icon on the top of the view grid frame to open a new dialog window with a Layer tab and an Edit Renderer tab.

Ent-Map_Widget_Editor_Layers_Add

2.On the Layer tab, select the desired Layer Type from the drop-down menu. Options on the Layer tab of the dialog window change depending on the selected layer type. Each layer type is described below.

Facility Layer

The Facility Layer type allows users to set options (e.g., symbology, labels, order) for this layer, similar to other Map Widget layers. To use a Facility Layer, select a facility from the Facility Chooser. Multiple facility layers can be configured on a single Map Widget.

My EQuIS Facilities

This layer is used to display all facilities. The Layer URL will automatically be populated with "api/facilities/FeatureServer/0". A simple renderer can be set up to display the facilities.

User Report

Plot a User Report as a layer on the Map. To use a User Report Layer, select a report (Report Chooser), configure the report options, and then configure the classification scheme.

Feature Layer

Plot an Esri Feature Layer, published alone, or as part of a Feature Service. To use a Feature Layer, provide the URL to the Feature Layer, and a layer name to display in the Layer List. Optionally, a username and password can be provided to access secure services.

ArcGIS Dynamic Layer

Allows the user to work with a dynamic map service resource exposed by the ArcGIS Server REST API. A dynamic map service generates images on the fly. To use a dynamic map service, provide the URL to the layer and a layer name to display in the Layer List. Optionally, a username and password can be provided to access secure services.

ArcGIS Tile Layer

Allows the user to work with a cached map service resource exposed by the ArcGIS Server REST API. A cached service accesses tiles from a cache instead of dynamically rendering images. To use a tiled map service, provide the URL to the layer and a layer name to display in the Layer List. Optionally, a username and password can be provided to access secure services. Tiled services can have custom levels of detail.

GeoRSS Layer

GeoRSS is a live web feed that includes geographic features and locations. For example, a transportation department might maintain a GeoRSS of current vehicle accidents in their local area. ArcGIS Server Dynamic Map Service Layer can only come from ArcGIS Server (either Esri, or hosted by someone else). To use a GeoRSS Layer, provide the URL to the layer and a layer name to display in the Layer List.

KML Layer

Allows the user to work with an image map service resource exposed by the ArcGIS Server REST API. It is an Esri KML layer, defined by URL. The URL MUST be accessible by Esri (not Intranet or firewalled location). To use a KML Layer, provide the URL to the layer and a layer name to display in the Layer List.

Image Layer

Allows the user to work with an image map service resource exposed by the ArcGIS Server REST API. It is an Esri Image Service layer. To use an Image Layer, provide the URL to the layer and a layer name to display in the Layer List.  

Vector Tile Layer

Plot an Esri Vector Tile layer. The URL can either be the layer URL or style JSON URL. Optionally, display levels can be set as a comma-separated list (11,12,13,14) and minimum scale and maximum scale can be defined.

CSV Layer

Plot a point layer based on a comma-separated values (CSV) file (.csv, .txt). A CSV file is a plain-text format used to represent tabular data and must include geographic point features (e.g., latitude, longitude).

3.Enter a Layer Name. The layer name will automatically populate when a facility or user report is chosen.

4.Enter the Web API URL for the layer in the Layer URL field. This will automatically be populated when a Facility Layer, My EQuIS Facilites, or User Report layer is selected as the map layer.

5.Set the layer default visibility by checking or un-checking the Visible by Default option.

6.Select the Show in Layer List option to have the layer available in the Layer List menu.

7.Set the Layer Opacity. This field allows the user to set the opacity of the layer. An opacity of '0' makes the layer fully transparent, while an opacity of '100' makes the layer fully opaque.

8.Depending on the selected layer type, other options might be available on the Layer tab of the dialog window. Set these options as appropriate. See the Popup Template section in this article for more detailed instructions on associating a popup window with a map layer.

9.For a Facility, My EQuIS Facilites, Feature, User Report or CSV layer, select the Edit Renderer tab in the dialog window. For all other layer types, go to Step 11.

10.Custom renderers determine how the data will appear (i.e., render) on the map layer. See the Custom Renderers section in this article for more detailed instructions on how to setup the renderer for a map layer.

11.Once all required fields have been entered/selected, the Add Layer button will be displayed. Click the Add Layer button to add the layer to the Map widget. The new layer will appear in the grid view of the Layers tab of the Map Widget Editor.  

 

 

Edit or Delete Existing Map Layer

 

To edit an existing map layer, select a layer (which will highlight it in blue) and click the Edit Layer Ent-Edit_Icon icon on the top of the view grid frame to open a new dialog window with a Layer tab and an Edit Renderer tab. Change settings as desired. See the Add New Map Layer, Popup Template and Custom Renderers sections for more details about layer options. Click the Save button to retain changes. Click the Cancel button to close dialog window without saving changes.

 

To delete an existing map layer, select a layer (which will highlight it in blue) and click the Delete Layer Ent-Delete_Icon icon on the top of the view grid frame. A message dialog will request confirmation before deleting the map layer.

 

 

Popup Template

 

Popup Templates are available for Facility Layers, Feature Layers, CSV Layers and User Reports by selecting a template from the drop-down menu. The available templates include Attribute Listing, Location Information, Time Series Chart, Crosstab, Feature Description, and Custom.

Ent-Map_Widget_Editor_Layers_Popup

 

 

 

 

 

 

 

 

 

Ent-Map_Widget_Editor_Layers_Popup_List

Attribute Listing – Displays all output values of the report.

Location Information – Displays the same information as Attribute Listing and Feature Description, but adds a list of all files (e.g., docs, photos) before the Attribute Listing.

Time Series Chart – Time series charts can be added to display when a location is selected. Refer to Time Series Chart for more information.

Crosstab – Displays a crosstab with column header = SAMPLE_DATE and row header = SAMPLE_NAME for every location.

Feature Description – Select to display the Attribute Listing.

Custom – A Custom Popup Template is displayed where the title and content can be set in the JavaScript Object Notation (JSON) Editor. Selecting the JSON Editor Ent-Dashboard_Properties icon will also open the JSON editing window. Widget properties can be manually edited in the window.

 

 

Custom Renderers

 

Custom renderers are available for Facility, My EQuIS Facilites, Feature, CSV, or User Report layers and determine how the data will appear on the map layer. A renderer must be defined for a User Report layer to work. When adding or editing a layer with a custom renderer, select the Edit Renderer tab on the dialog window. The Renderer Type options include simple, unique value, and class breaks. Select the drop-down menu to choose the Renderer Type.

Ent-Map_Widget_Editor_Layers_Renderer_Types-blank

 

 

Ent-Map_Widget_Editor_Layers_Renderer_Types

Simple – Displays the defined symbology for the map layer.

Unique Value – Allows user to select an attribute field to display on the map with the defined symbology.

Class Breaks – Allows user to select an attribute field and define a classification scheme for how the plot values will be grouped for display on the map with the defined symbology.

For each of the custom renderers, symbology must be set. This includes symbol type, style, size, and color.

 

Class Breaks

When the Class Breaks renderer is used, additional options must be selected.

Ent-Map_Widget_Editor_Layers_Renderer_Class-Breaks

Field Attribute – This field allows the user to filter the displayed results.

Min – Displays the minimum value of the selected field attribute.

Max – Displays the maximum value of the selected field attribute.

Count – Displays the number of values of the selected field attribute.

Ent-Map_Widget_Editor_Layers_Renderer_Class-Breaks3

Classification Scheme – The classification scheme defines how the plot values will be grouped for display on the map. Members of each group will be displayed with the same symbol, and usually defined in the legend. Classification scheme options include:

Equal Interval – Plots values in automatically calculated equal intervals. The number of intervals is specified in Number of breaks field.

Defined Interval – Plots values in the intervals defined. Set the required interval in the Interval field (e.g., 100).

Quantile – Classifies data into a certain number of categories with an equal number of units in each category. The number of categories is specified in Number of breaks field.

Manual – Type pipe-separated values in the Values field to define the manual breaks.

 

Select the drop-down menu to choose the Classification Scheme. Set the necessary options and click the Generate button to create the class breaks. Each group can subsequently be edited.

Ent-Map_Widget_Editor_Layers_Renderer_Classification

 

 

Set View Order of Map Layers

 

If two or more layers are added to the Map widget, a user can adjust the order that the layers are displayed on the map interface. When the map loads, layers are drawn in the order that the layers are displayed in the view grid within the Widget Editor. In the example below, layer L1 will be drawn first, then layer L2, and then layer L3. Therefore, L3 will be the top-most layer visible on the map.

Ent-Map_Widget_Layer_Order1

To change the display order: (1) select a layer (which will highlight it in blue), (2) click and hold down the selected layer, and (3) drag it to the desired position in the list of layers (view grid). After dragging the layer to the new position, the blue highlighting will be removed. To preserve the revised order of the layers, click Save on the Widget Editor header. The map will reload and draw the layers in the revised order.

 

In the example, layer L3 is selected and dragged to the first position in the view grid. When the map reloads, layer L3 will be drawn first, then layer L1, and then layer L2. Now L2 will be the top-most layer visible on the map.

Ent-Map_Widget_Layer_Order2

Ent-Map_Widget_Layer_Order3

 

Note: A layer cannot be moved to the bottom position in the view grid (i.e., the top-most display layer on the map). To make a layer the top-most layer on the map, move the layer(s) beneath it to a higher position in the view grid.

 

Using the current example, perform the following steps to move layer L3 back to the bottom position in the view grid. Select layer L3 and drag layer L3 below layer L1. Select layer L2 and drag layer L2 above layer L3. Now the layers are returned back to the original order. Save the changes and the map will redraw layer L1 first, then layer L2, and then L3 as the top-most layer.