XY Chart Basics: Chart Toolbar

<< Click to Display Table of Contents >>

EQuIS 7  >>  Professional > XY/XYZ Charts > XY Charts >

XY Chart Basics: Chart Toolbar

After running a report and clicking on XY Charts to create charts, the Chart Toolbar (Figure 1) is displayed above the empty chart area and it contains File, View and quick tool buttons.

 

Figure 1

Figure 1

 

File

 

File > Load Template: Loads a saved chart template xml file.
Note loading a template may not retrieve all saved properties of a chart. Users are welcome to report issues to EarthSoft Inc. so they can be corrected based on needs.

File > Save Template: Saves the properties of the active chart into a chart template xml file.
Note saving a template may not save all the saved properties of a chart. Users are welcome to report issues to EarthSoft Inc. so they can be corrected based on needs.

File > Recent Templates: Lists currently saved chart template xml files so that users can conveniently select one to load.

File > Export: Exports all the charts to a user-selected folder as image files.

File > Send To > Outlook: Exports active chart to a jpg image file and opens message editing window of outlook.exe (if installed) with the image file attached.

File > Send To > Excel: Exports all the charts to an Excel file. To view the raw data in the Excel chart export, right-click on a worksheet tab and choose Unhide from the context menu; click a worksheet from the list of the hidden "Data" worksheets to unhide it.

File > Send To > My Charts: Exports all the charts as image files to a user-selected folder.

File > Close: Closes the chart window.

 

View

 

View > Data: Displays or activates Data tab

View > Advanced > Active Chart: Displays the properties of the active chart in Advanced tab.

View > Advanced > All Charts: Displays the properties of all the charts in Advanced tab.

View > Advanced > All Series: Displays the properties of all the series of all the charts in Advanced tab.

View > Advanced > All '{0}' Series: Displays the properties of the selected series of all the charts in Advanced tab. Note deselect one or more series legends and click on View > Advanced > All '...' Series which re-selects the deselected series and displays the properties of the selected series of all the charts in Advanced tab (Figures 2 and 3).

 

Please note that once some of the chart series are selected/displayed in All '...' Series, they are remembered there until the charts are cleaned by doing Clear Series. Because of this feature, you can reverse the changes done to the series of All '...' Series sometime later by re-selecting All '...' Series.

 

Warning: When one of the View > Advanced > items is selected, users should not click on the chart area until finished editing the properties in the Advanced tab. For example, if you click on the center of the chart area, axes area or chart name tab etc, Advanced tab may no longer display what you selected over the View > Advanced >.

 

Example 1 of use All '{0}' Series: see Combine Multiple Reports in XY Chart or Setup Secondary Y Axis

Example 2 of use All '{0}' Series: see Remove Series From Charts

 

Figure 2 shows how to Do All '{0}' Series. First deselect ACETONE and Antimony Series of all the charts. Next, select View>Advanced>All "..." Series.

 

Figure 2

Figure 2

 

Figure 3 shows how to Do All '{0}' Series. After clicking All '...' Series, deselected series are reselected, and the properties are in the Advanced tab. Changes in the Advanced tab apply to all charts.

 

Figure 3

Figure 3

 

Quick Tool Buttons in Chart Toolbar

 

Turn On/Off Current Chart Editor: Turns on or off the Chart Editor for the active chart. See details in XY Chart Basics: Chart Editor.

Send the current chart to an email: Exports the active chart to a jpg image file and opens the message editing window of outlook.exe (if installed) with the image file attached.

Send To Excel: Exports all the charts to a user-selected folder as image files. To view the raw data in the Excel chart export, right-click on a worksheet tab and choose Unhide from the context menu, and click a worksheet from the list of the hidden "Data" worksheets to unhide it.

Send To My Charts: Exports all the charts  as image files to an auto-generated folder.

Print: Exports all the charts as image files to the newly created ... \My EQuIS Work\...\ (Chartsyyyy-MM-dd hhmmss) folder and opens the files with a default picture viewer associated to the image type so that users can print them after reviewing them.

Load Template: Loads a saved chart template xml file. Note loading a template may not retrieve all the saved properties of a chart and users are welcome to report issues to EarthSoft Inc. so that they can be corrected based on needs.

Save Template: Saves the properties of the active chart into a chart template xml file. Note that saving a template may not save all the saved properties of a chart and users are welcome to report issues to EarthSoft Inc. so that they can be corrected based on needs.

Add Annotation: Adds annotations to the active chart. See details in Add Images and Annotations.

Add Image: Adds images to the active chart. See details in Add Images and Annotations.