EQuIS Database Must Be Updated

<< Click to Display Table of Contents >>

EQuIS 7  >>  EnviroInsite > Frequently Asked Questions > Troubleshooting Error Messages >

EQuIS Database Must Be Updated

The error messsage "This database must be updated to comply with the current version of EQuIS" occurs when connecting to an EQuIS database, where the EQuIS dll files provided with EnviroInsite are more up-to-date than the database that the user is trying to connect to.  EnviroInsite ships with the following EarthSoft dll files: EarthSoft.Registration.dll, EarthSoft.Common.dll, EarthSoft.EQuIS.dll, and (EI 7 only) EarthSoft.Helpers.dll. As of EI7, these files are for EQuIS 7.

 

If EnviroInsite is called upon by the user to connect to an EQuIS database consistent with version 5.6, then this error message will appear, and the connection will not succeed. The work-around for this is to:

1.Backup the EarthSoft dlls in the EnviroInsite application folder.

2.Copy the versions of the dlls from the EQuIS application folder.

3.Paste them into the EnviroInsite application folder.